Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-05-2005, 12:11 PM   #1
Aquarium Advice Freak
 
Join Date: May 2005
Location: Cherry Hill New Jersey
Posts: 238
Rio 600 pump froze up

My PH stoped working. Seems that it froze up. Took it apart and cleaned the parts up a bit, but to no avail. I hear the inside vibrating when I plug it in, so I know the power is getting through.

Is it fried?

Mike
__________________

__________________
120 g FOWLR, Pro Clear 200 19 gal. sump (bio balls removed), 50# Walt Smith FiJi LR, 150# reefersrock base, 300# DSB, Iwaki MD 20 return, (2) Rio 600s, (2) Hagen 802s, Amiracle Quad II skimmer, (2) Coralife 4 X 65s, 2 Lebo moonlights, (2) 120 mm vent. fans,

(2) Perc. Clowns, (1) Yellow Tang, (1) cleaner shrimp, (2) Henis, pending: Foxace Lo, Flame Angel, blue legs, scarlets, 4 emerald crabs, nassarius snails, 50 mexican turbos, (1) good bankruptcy attorney when this hobby blows out of control!
spinman is offline   Reply With Quote
Old 11-05-2005, 11:07 PM   #2
SW REEF 18+ YEARS
Community Admin
 
melosu58's Avatar



Tank of the Month Award
 
Join Date: Oct 2004
Location: Virginia
Posts: 38,249
Sounds like one of the parts is not working. Take it apart again and see if any parts need adjusting
__________________

__________________

SITE ADMINISTRATOR

You can view many of my fish and corals in my photo albums in my profile.

View my tank


AA Community Rules|AA TOS

Forums 101 - posting, accounts, basics
melosu58 is offline   Reply With Quote
Old 11-06-2005, 02:55 AM   #3
Aquarium Advice Addict
 
Join Date: May 2005
Location: Central Kentucky
Posts: 6,015
Send a message via AIM to greenmaji
try soaking the parts in vinigar.. sounds like the impeller head isnt making proper contact if your getting a rattle.. could just need adjustment or a cleaned a little better..
__________________
greenmaji is offline   Reply With Quote
Old 11-08-2005, 08:09 AM   #4
Aquarium Advice Freak
 
Join Date: May 2005
Location: Cherry Hill New Jersey
Posts: 238
I was ready to sh*tcan the **** PH when I decided to take apart the other working 600 I had to see if there were any differences between the two. It seems the chrome shaft on the working 600 moved freely while the shaft on the busted PH was frozen. I banged the shaft loose, scoured it with a green scotch brite pad and reassembled.

Works like a charm now.

Mike
__________________
120 g FOWLR, Pro Clear 200 19 gal. sump (bio balls removed), 50# Walt Smith FiJi LR, 150# reefersrock base, 300# DSB, Iwaki MD 20 return, (2) Rio 600s, (2) Hagen 802s, Amiracle Quad II skimmer, (2) Coralife 4 X 65s, 2 Lebo moonlights, (2) 120 mm vent. fans,

(2) Perc. Clowns, (1) Yellow Tang, (1) cleaner shrimp, (2) Henis, pending: Foxace Lo, Flame Angel, blue legs, scarlets, 4 emerald crabs, nassarius snails, 50 mexican turbos, (1) good bankruptcy attorney when this hobby blows out of control!
spinman is offline   Reply With Quote
Reply

Tags
pump, rio

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rio 600 a heat monster!! Raker333 General Hardware/Equipment Discussion 5 01-07-2006 01:22 AM
rio pump mrkho General Hardware/Equipment Discussion 1 10-20-2005 10:44 AM
Anyone use or have a RIO Hyperflow pump? gooyferret General Hardware/Equipment Discussion 14 05-17-2005 02:43 PM
Ever use a Rio Seio pump?? MT79 General Hardware/Equipment Discussion 0 03-18-2005 08:19 PM
Rio pump? medge00 Freshwater & Brackish - General Discussion 6 02-18-2004 12:18 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 02:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.