Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 05-17-2009, 12:22 AM   #1
Aquarium Advice Apprentice
Join Date: May 2009
Posts: 10
Angry RO Filter Problem

I bought a Coralife RO/DI Pur Flo 3 50GPD unit about 2 years ago when I was last into salt. When I shut down my salt tank about 6 months ago I took the coralife apart And stored the membrane in the case in the fridge. Well I am getting back into Saltwater and am trying to get this RO Filter running again.

I'm sure I have all the plumbing right as far as sequence. I have tested pressure upto the RO Unit and everything runs fine. EVerytime I plumb it through the RO Unit I get no production and it usually pops a seal/hose and leeks. With nothing coming throught the filter.

Is it possible that the RO Membrane is shot and if so would that stop water coming through completely and cause a pressure burst?

I Kinda want to figure out exactly what it is before putting money down on a new membrane or even worse a whole new filter.


graceinhim is offline   Reply With Quote
Old 05-22-2009, 05:04 PM   #2
Aquarium Advice Apprentice
Join Date: Jun 2008
Location: newark,de
Posts: 34
was the membrane dried out when you put it back in the unit?I think if you would soak the membrane for 24 hours in water maybe it will come back, also, i think i would recheck all the plumbing lines, test each line indivilualy, you may find a blockage in one.

dropin is offline   Reply With Quote
Old 05-22-2009, 05:16 PM   #3
Community Admin
melosu58's Avatar

Tank of the Month Award
Join Date: Oct 2004
Location: Virginia
Posts: 37,887
I`m thinking it dried out also. you might have to get a new membrane.
melosu58 is offline   Reply With Quote
Old 05-22-2009, 06:41 PM   #4
Aquarium Advice Addict
thincat's Avatar
Join Date: Nov 2008
Posts: 5,330
Try taking out the membranes one at a time and running the water to see if it goes through. That way you can isolate the problem.
Happy Reefing,
thincat is offline   Reply With Quote


Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is filter the problem? babyblue4020 Saltwater & Reef - Sick Fish or Coral 3 10-27-2008 08:43 PM
Filter Problem MarkW19 Saltwater Reef Aquaria 4 10-22-2007 01:01 PM
Filter problem. Joey17 General Hardware/Equipment Discussion 11 12-23-2005 10:36 AM
Filter Problem?? pioneer27 General Hardware/Equipment Discussion 5 10-13-2005 11:45 PM
Problem with my Filter Guam General Hardware/Equipment Discussion 2 09-30-2002 07:14 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 09:24 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.