Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-24-2011, 03:00 PM   #1
WMC
Aquarium Advice Apprentice
 
Join Date: Jan 2011
Location: Houston
Posts: 32
RODI filters have Algae

I have just recently started using an RODI filter. I see the filters have turned brown with what I assume is algae. Is this normal? If not, what do I need to do to stop this?
Thanks in advance
__________________

__________________
WMC is offline   Reply With Quote
Old 03-25-2011, 12:58 PM   #2
Aquarium Advice Addict
 
Smitty's Avatar
 
Join Date: Nov 2008
Location: Gainesville, FL
Posts: 1,206
I don't have any experience with an RO/DI yet but from what I've read that brown is not alga, it is the sediment that is being removed from the water (or something to that effect).

Someone please correct me if I'm wrong!
__________________

__________________
Smitty is offline   Reply With Quote
Old 03-25-2011, 07:28 PM   #3
Aquarium Advice Addict
 
Ricksreef's Avatar
 
Join Date: Mar 2011
Location: Newport News
Posts: 1,109
Smitty is correct.The unit is doing what it is supposed,remove all that crap from the water. You will need change the filters eventually,just keep testing the water and you will know when you need to replace them.
__________________
Ricksreef is offline   Reply With Quote
Reply

Tags
algae, filter, filters, rodi

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new rodi skae310 General Hardware/Equipment Discussion 15 12-26-2009 06:57 PM
RODI unit skae310 Saltwater Reef Aquaria 8 11-15-2009 02:48 PM
RODI - Which one do you have? fishman Saltwater Reef Aquaria 17 01-07-2007 09:39 AM
RODI OceanMist Saltwater Reef Aquaria 12 09-29-2006 02:53 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.