Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-24-2009, 02:36 PM   #1
Aquarium Advice Regular
 
Join Date: Sep 2004
Location: Sacramento CA
Posts: 98
Should I replace my Mag-Drive 7 pump or just buy a new impeller?

I have a Mag-Drive 7 pump in my sump that serves as my return pump. I recently unplugged it to clean the tank and it made a humming noise when I plugged it back in, but it didn't pump any water. I shook it around a bit and it started working again, but it doesn't seem to be pumping as hard. This routine seems to happen whenever I unplug it for maintenance. I examined the impller and didn't notice any problems. I noticed that Mag-Drive advertises that their pumps have low maintenance because there is only one moving part (the impeller). My question is should I buy a replacement impeller for the pump or do I need to buy a new pump altogether?

Also, I didn't notice any obstructions in the return tubing that would've caused a reduction in water current so I'm pretty sure it's the pump...
__________________

__________________
bodie is offline   Reply With Quote
Old 03-24-2009, 02:41 PM   #2
AA Team Emeritus
 
austinsdad's Avatar


 
Join Date: Mar 2004
Location: Accokeek, Maryland
Posts: 7,694
I recommend ANYONE and EVERYONE have a back up impeller for their main pump. Don't wait until it goes bad to order one or look for a store that has it in stock.

I'd replace the impeller anyway if it were me. Try that first.
__________________

__________________
-Ray-

"Life may not be the party we hoped for but while we are here we might as well dance!"

austinsdad is offline   Reply With Quote
Old 03-24-2009, 03:11 PM   #3
AA Team Emeritus
 
Ziggy953's Avatar



POTM Champion
Tank of the Month Award
 
Join Date: Feb 2006
Location: Owings Mills, Maryland
Posts: 9,101
I have 4 Danner Mag Drive pumps. I've never had that issue with any of mine. I would take it apart again and make sure the impeller is seated properly and that the O-ring around the faceplate isn't inside the pump. I agree with Ray though, it is always a good idea to have a backup! I keep a couple of spare pumps just in case as well as impellers for my main pumps.
Ziggy953 is offline   Reply With Quote
Old 03-26-2009, 03:09 PM   #4
Aquarium Advice Regular
 
Join Date: Sep 2004
Location: Sacramento CA
Posts: 98
Thanks for the advice. I checked everything again, but it didn't resolve anything. Considering I can't diagnose the problem, I suppose I should skip buying an impeller and just buy an entirely new pump.

Any thoughts on a more reliable brand or type of pump than mag-drive?
__________________
bodie is offline   Reply With Quote
Old 03-26-2009, 03:26 PM   #5
AA Team Emeritus
 
Ziggy953's Avatar



POTM Champion
Tank of the Month Award
 
Join Date: Feb 2006
Location: Owings Mills, Maryland
Posts: 9,101
What you have is one of the most reliable pumps on the market.
Ziggy953 is offline   Reply With Quote
Old 03-26-2009, 06:25 PM   #6
Aquarium Advice Regular
 
Join Date: Sep 2004
Location: Sacramento CA
Posts: 98
Thanks Ziggy! I suppose I will start with a replacement impeller and then if that doesn't work, I will buy a new Mag-Drive 7. I suppose worst case scenario is that I will have an extra impeller in case this happens again. I just didn't want to invest money into an inferior brand, but since you're saying it's reliable, I'll stick with it. I don't really have any experience with any other brand of pumps. Thanks again!
__________________
bodie is offline   Reply With Quote
Old 03-26-2009, 07:25 PM   #7
Aquarium Advice Freak
 
jim692's Avatar
 
Join Date: Jan 2009
Location: southeast, PA.
Posts: 387
Did you try to contact the Danner Mfg. support line?
DANNER MFG HOMEPAGE

They may be able to help with your problem. After all they made the pump.
__________________
Jim
jim692 is offline   Reply With Quote
Old 03-26-2009, 07:37 PM   #8
Aquarium Advice Regular
 
Join Date: Sep 2004
Location: Sacramento CA
Posts: 98
Good thinking jim692! I hadn't thought of that, but I'll give that a try before ordering anything. Thanks for the advice!
__________________

__________________
bodie is offline   Reply With Quote
Reply

Tags
impeller, pump

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mag Drive Pump fishman Saltwater Reef Aquaria 6 06-07-2007 08:31 PM
Aqua C Remora Pro w/ Mag-Drive 3 Pump Mackey256 Archive 0 05-18-2007 12:42 PM
Mag drive pump with metal screws for saltwater? bodie General Hardware/Equipment Discussion 2 02-28-2006 11:37 PM
My Mag Drive Headache, New pump? Bearfan General Hardware/Equipment Discussion 3 10-21-2004 01:42 PM
A Little Help - Mag Drive Pump Broken Bearfan Saltwater Reef Aquaria 3 01-13-2004 05:59 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.