Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 10-13-2012, 03:57 PM   #1
Aquarium Advice Addict
 
jcolon's Avatar
 
Join Date: Mar 2011
Location: Long Island NY
Posts: 3,470
Send a message via AIM to jcolon Send a message via Skype™ to jcolon
So long C4 ... don't let the door knob it ya!

This is just not my week and month (so far) with filters. First, the demise of my old trusted Fluval 404 and then today ... I had to let my 3day old Fluval C4 go. It's flow would slow way down ... for no reason that I could see. The intake was set correctly, media was placed fine, impeller seemed to work fine. Go figure. Twice I had to work with it and this morning I gave it it's walking papers and sent it on it's way! Well, I suppose I did have to take it back to Petsmart.

But, they did have the AC-70 I originally wanted and got refunded back almost $20. So far the AC-70's working great ... but I've been fooled already I will wait till after the weekend for my final verdict.
__________________

__________________
75g Planted Barbs Denison, BlackRuby, Tiger, Albino Tiger, Green Tiger, Cherry, Gold, Checkered, Odessa.
NonBarbs Cardinal, Neon, RummyNose, Bloodfin Tetras, Z. Danios. 1RTS. Amano, Bamboo, Ghost & RCS. 20g Long Shrimp Tank RCS, Tiger, Amano.
jcolon is offline   Reply With Quote
Old 10-13-2012, 04:00 PM   #2
Aquarium Advice Addict
 
Nu-Nu the eel's Avatar
 
Join Date: Aug 2011
Location: So Cal
Posts: 5,455
Thats too bad... I had an AC70 before and it worked like a charm
__________________

__________________
Nu-Nu the eel is offline   Reply With Quote
Old 10-15-2012, 07:24 AM   #3
Aquarium Advice Addict
 
Beengirl's Avatar
 
Join Date: Jul 2012
Location: Michigan
Posts: 3,308
Too bad about the Fluval. I have an AC 70 on my 30g, works great so far!!
__________________
Beengirl is offline   Reply With Quote
Old 10-15-2012, 12:06 PM   #4
Aquarium Advice Addict
 
jcolon's Avatar
 
Join Date: Mar 2011
Location: Long Island NY
Posts: 3,470
Send a message via AIM to jcolon Send a message via Skype™ to jcolon
I must say, although technically I should be using an AC-110 for my 75gal ... I've been very impressed with the flow rate of this AC-70. Considering I have it stuffed with Ceramic Rings and Foam sponges from my old 404, the waterfall is enough to send my Danios hurling around.

That and my son's old Marineland HOB gives me about 90-95gallons worth of filtration.
__________________
75g Planted Barbs Denison, BlackRuby, Tiger, Albino Tiger, Green Tiger, Cherry, Gold, Checkered, Odessa.
NonBarbs Cardinal, Neon, RummyNose, Bloodfin Tetras, Z. Danios. 1RTS. Amano, Bamboo, Ghost & RCS. 20g Long Shrimp Tank RCS, Tiger, Amano.
jcolon is offline   Reply With Quote
Reply

Tags
long

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 05:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.