Go Back   Aquarium Advice - Aquarium Forum Community > Community Forum > Forum Admin & Announcements
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 01-27-2006, 11:07 PM   #1
Aquarium Advice Apprentice
 
Join Date: Jan 2006
Location: Denver, CO
Posts: 33
Control-click issue

When I am browsing forums with Firefox, I like to control-click on interesting threads to open them in a new tab while I continue to scroll down the list of topics in the forum. Then I go through and read all the threads that I opened in their own tab.

When I try and do this on Aquarium Advice, Firefox will open a new tab but also change the current tab to that thread at the same time. If I right-click on the link and select "open in new tab" everything works as normal. Control-click just doesn't work like it should because the current window goes to the link. This behavior doesn't seem to happen on other sites, but the ones I am on frequently are based on vBulletin.

Any idea why this happens? Is it by design? or is there some funky javascript that is forcing the current tab to update?
__________________

__________________
weldon is offline   Reply With Quote
Old 01-27-2006, 11:55 PM   #2
AA Team Emeritus
 
Join Date: May 2002
Location: Virginia
Posts: 2,256
Send a message via ICQ to fishfreek Send a message via AIM to fishfreek Send a message via MSN to fishfreek Send a message via Yahoo to fishfreek
I dont use CTRL+Click to do what you describe but I click the center scroll wheel to open in new tab. When I do this I have no problem with the current tab changing.
__________________

__________________
Remember dont tap the glass, your fish will think you're an idiot -Anonymous mother

Check out our articles area. 30+ Aquatic articles for your enjoyment
Are you in or around the Shenandoah Valley area? If so click here to join our regional forum.
fishfreek is offline   Reply With Quote
Old 01-28-2006, 12:01 AM   #3
AA Team Emeritus
 
Join Date: May 2002
Location: Virginia
Posts: 2,256
Send a message via ICQ to fishfreek Send a message via AIM to fishfreek Send a message via MSN to fishfreek Send a message via Yahoo to fishfreek
I just tested CTRL+Click and the primary window does not change. It only opens a new tab.
__________________
Remember dont tap the glass, your fish will think you're an idiot -Anonymous mother

Check out our articles area. 30+ Aquatic articles for your enjoyment
Are you in or around the Shenandoah Valley area? If so click here to join our regional forum.
fishfreek is offline   Reply With Quote
Old 01-28-2006, 12:08 AM   #4
Aquarium Advice Apprentice
 
Join Date: Jan 2006
Location: Denver, CO
Posts: 33
Thanks for checking. I tried the wheel click and this works normally. Control-click still changes the current tab (there's a one or two second delay after the other tab opens). I've tried this on three different machines now, including an Apple Powerbook with the Safari web browser (command-click on the Mac). Since this is happening on multiple machines and with different browsers, could it be a user option in the board settings that I missed?
__________________
10g / TopFin 10
4 Leopard Danios - TBA 1 Red Dwarf Gourami
weldon is offline   Reply With Quote
Old 01-28-2006, 12:13 AM   #5
AA Team Emeritus
 
Join Date: May 2002
Location: Virginia
Posts: 2,256
Send a message via ICQ to fishfreek Send a message via AIM to fishfreek Send a message via MSN to fishfreek Send a message via Yahoo to fishfreek
There are no user options to govern how clicking on a topic works. A note. If you click on the new topic icon (orange icon) it should open in the same window. If you click on the link it should open in a new window. This is the action if you use IE. Not sure if instead of a new window you get a new tab in FF as I only wheel click. I am using FF Version 1.5
__________________
Remember dont tap the glass, your fish will think you're an idiot -Anonymous mother

Check out our articles area. 30+ Aquatic articles for your enjoyment
Are you in or around the Shenandoah Valley area? If so click here to join our regional forum.
fishfreek is offline   Reply With Quote
Old 01-28-2006, 12:26 AM   #6
Aquarium Advice Apprentice
 
Join Date: Jan 2006
Location: Denver, CO
Posts: 33
That's what the problem is...

It only happens on the links to forum threads. I'm in the habit of using the text link and there is a funky javascript behavior when you control-click on these links. It will open the new tab and also change the current tab. When I control-click on the icon on the left, this doesn't happen (mine is blue rather than orange - different skin I guess). This funky behavior happens with the links to "view newest post" and the page number links as well.

OK, problem solved. I'll just click on the "button" on the left or use wheel-click.

Incidentally, clicking on the text link to a thread in IE doesn't open a new window. If it doesn't accomplish what it was meant to do, maybe you should just remove that "feature" so it doesn't mess up other browsers.
__________________
10g / TopFin 10
4 Leopard Danios - TBA 1 Red Dwarf Gourami
weldon is offline   Reply With Quote
Old 01-28-2006, 12:28 AM   #7
Aquarium Advice Apprentice
 
Join Date: Jan 2006
Location: Denver, CO
Posts: 33
Also, the funky behaviour stops when I turn off javascript in Firefox. Which is why I blamed javascript above. I just wanted to be clear.
__________________
10g / TopFin 10
4 Leopard Danios - TBA 1 Red Dwarf Gourami
weldon is offline   Reply With Quote
Old 01-28-2006, 12:52 AM   #8
AA Team Emeritus
 
reefrunner69's Avatar
 
Join Date: May 2002
Location: Cedar Key, FL
Posts: 1,663
Quote:
ncidentally, clicking on the text link to a thread in IE doesn't open a new window.
Does for me. Also works in Opera, as it was intended and it works perfectly fine on my copy of firefox as well. The search page does not change to the clicked page, either using ctrl + left click or simly left clicking. What style are you using, perhaps it is an issue with a certain style.
__________________
Kevin

Visit Nature Coast Photography
reefrunner69 is offline   Reply With Quote
Old 01-28-2006, 01:59 PM   #9
Aquarium Advice Apprentice
 
Join Date: Jan 2006
Location: Denver, CO
Posts: 33
I've been using the fisubice style, but I tried a few different styles and got the same behavior in each one. Some styles don't seem to have a clickable icon to the left of the thread title so I couldn't check that part of it, but the text links all work the same way.

When I'm looking at the list of subscribed topics, clicking on those text links to the thread WILL open a new browser window. Control-clicking from that page will NOT change the current tab. However, as soon as I go to a forum index, I see the same issue where, when clicking on the text link (which is the thread topic title) with wheel-click or right-click to select "open in a new tab" work fine, but control-click will open a new tab and change the current tab.

Again, this is only from the forum index page when I control-click on the text link (thread title)

Turning javascript off will fix the "strange" behavior. I'm only running two extensions: SessionSaver (which is great, BTW) and DOM Inspector. Both are the latest versions.

I can't figure out what could be different about my system, but I can confirm that this is a problem on Firefox 1.5 on WinXP and Safari 2.03 on Mac OS X v10.4.4. It's not just that one computer. I tried logging out and removing all my cookies for aquariumadvice.com and I still see the same behavior.

At this point, I'm just curious as to why I see it you don't.
__________________
10g / TopFin 10
4 Leopard Danios - TBA 1 Red Dwarf Gourami
weldon is offline   Reply With Quote
Old 01-28-2006, 02:03 PM   #10
Aquarium Advice Apprentice
 
Join Date: Jan 2006
Location: Denver, CO
Posts: 33
Quote:
Originally Posted by reefrunner69
The search page does not change to the clicked page, either using ctrl + left click or simly left clicking.
Not sure what you meant, but just to be clear, I only see this behavior when I'm looking at the forum page with the list of current threads. This does NOT happen when I look at search results, the list of posts I'm watching, etc.
__________________

__________________
weldon is offline   Reply With Quote
Reply

Tags
control, ick

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will mantis shrimps' click break glass??? weekf Saltwater Reef Aquaria 1 10-27-2006 10:13 PM
Ph issue DiverDown Freshwater & Brackish - General Discussion 9 10-07-2006 05:20 PM
click, click, click.......... lovemybarbs Freshwater & Brackish - General Discussion 2 07-16-2006 01:29 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.