Aquarium Advice - Aquarium Forum Community

Aquarium Advice - Aquarium Forum Community (http://www.aquariumadvice.com/forums/)
-   General Hardware/Equipment Discussion (http://www.aquariumadvice.com/forums/f60/)
-   -   Marineland magniflow c360 (http://www.aquariumadvice.com/forums/f60/marineland-magniflow-c360-342199.html)

mikey5290 10-16-2015 07:33 PM

Marineland magniflow c360
 
:banghead::banghead: Just bought a Marineland magniflow c360 canister filter and the microbubbles are driving me crazy. I have had this thing apart more in four days than I thought I would have to in a year.
Bought this as an upgrade to the HOB's and regretting it already.

Anyone have any tips from experience? I have tried lubing the valve block o-rings, unhooked and reinstalled the intake hose, added another hose clamp to the intake (at the valve block).

So frustrated:banghead::banghead:

Mike

PoppaRyno 10-16-2015 07:36 PM

Have you tried tilting it in all directions while running? It can help release trapped air that priming misses.

Sent from my SPH-L710 using Aquarium Advice mobile app

mikey5290 10-16-2015 07:42 PM

I did try tipping it, and gently banging it while running trying to get all air out. The bubbles come in small bursts, 5-15sec apart.
Marineland customer support has been trying to help, but so far nothing they have susseted has helped. They suggested lubing the main gasket; but I have nothing at the moment that I would consider aquarium safe. I would think the lube would be included if it was a normal thing that needs to be applied to seal the unit.

PoppaRyno 10-16-2015 07:47 PM

Take that thing back and get a fluval or a sunsun. Marineland stinks IMO.

Sent from my SPH-L710 using Aquarium Advice mobile app

PoppaRyno 10-16-2015 07:48 PM

If the customer support staff cant help then its exchange time.

Sent from my SPH-L710 using Aquarium Advice mobile app

mikey5290 10-16-2015 08:49 PM

I was thinking that. Have to contact Petsmart first about return policy especially before I unhook everything.

PoppaRyno 10-16-2015 08:51 PM

Good luck, man. Hope it gets resolved. I Hate to see a fellow hobbyist struggle.

Sent from my SPH-L710 using Aquarium Advice mobile app

mikey5290 10-16-2015 08:54 PM

Thank you.

54seaweed 10-16-2015 09:32 PM

try adding a foam pre-filter over the strainer on the bottom of intake tube ,
also be sure the propeller is fully seated if it's not that could cause micro bubbles
marinland filters are just too loud IMO
Call the number on your instruction manual if you still encounter issues ,
once a filter is opened and used most pet stores ask you to contact the manufacturer

PoppaRyno 10-16-2015 09:37 PM

He already has been trouble shooting with marineland customer support. They cant figure it out either.

Sent from my SPH-L710 using Aquarium Advice mobile app


All times are GMT -4. The time now is 06:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.