Go Back   Aquarium Advice - Aquarium Forum Community > Freshwater > Freshwater & Brackish - General Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-21-2012, 06:49 PM   #1
Aquarium Advice Newbie
 
CraigIsGod's Avatar
 
Join Date: Jun 2012
Posts: 4
My filter has died i think!!? Helppp

My filter has stopped working I leave it for a while then Let it run again and it stops in like 20 seconds and I can hear a slight fiz and it turns off again. It is also slightly warm on the back where I suppose the miter is.

Thanks guys.
__________________

__________________
CraigIsGod is offline   Reply With Quote
Old 06-21-2012, 07:32 PM   #2
Aquarium Advice Obsessed
 
Mumma.of.two's Avatar


 
Join Date: Jul 2011
Location: Sunny Queensland, Australia
Posts: 11,142
What kind of filter? Have you checked that there is nothing lodged in the impeller?
__________________

Mumma.of.two is offline   Reply With Quote
Old 06-22-2012, 03:20 AM   #3
Aquarium Advice Newbie
 
CraigIsGod's Avatar
 
Join Date: Jun 2012
Posts: 4
I'm not shore, I'll have to check when I get home from work. There's abit of algae but it's just over heating, then stopping but then will keep working for another 20 seconds once left for a bit. I took apart and checked but couldn't see into the moter part not able to take apart.

Thanks for help
__________________
CraigIsGod is offline   Reply With Quote
Old 06-22-2012, 03:47 AM   #4
Aquarium Advice Obsessed
 
Mumma.of.two's Avatar


 
Join Date: Jul 2011
Location: Sunny Queensland, Australia
Posts: 11,142
Make sure to keep the media wet so you don't loose the bacteria. I had the same problem with one of mine. Turned out the intake pipe was pushed onto the impeller to hard and was causing it to stop.
Mumma.of.two is offline   Reply With Quote
Old 06-22-2012, 10:06 AM   #5
Aquarium Advice Newbie
 
CraigIsGod's Avatar
 
Join Date: Jun 2012
Posts: 4
So how do I sort this problem out if it is that. Recently I have purchased 2 new fish a green spotted puffer and a cat fish, and there wasn't enough oxygen in the water so my filter is able to be sunk or just sit straight up with just the tip out of the water then I switch on for bubbles and iv been leaving it there.
Attached Thumbnails
Click image for larger version

Name:	image-2399146338.jpg
Views:	46
Size:	63.3 KB
ID:	102169   Click image for larger version

Name:	image-288846530.jpg
Views:	43
Size:	29.8 KB
ID:	102170  

__________________
CraigIsGod is offline   Reply With Quote
Old 06-22-2012, 10:11 AM   #6
Aquarium Advice Addict
 
LyndaB's Avatar
 
Join Date: Jul 2011
Location: Connecticut
Posts: 5,816
According to their website, you are able to remove the impeller. Hope this helps.

http://www.aquariumadvice.com/forums...ml#post1993724

See if this previous thread helps, read it through.

http://www.aquariumadvice.com/forums...ng-120962.html
__________________
75: blood parrots, featherfin cat, emperor tetras, turquoise rainbowfish, BN plecos, japanese trapdoor; 46: WCMM, gold inca snails, ghost, bamboo & amano shrimp, kuhli loaches, rummynose & ember tetras, endlers, platies, flame gourami, guppies; 16: pygmy, peppered, loxozonus corys, otos, assassins, RCS ... ~ Research PRIOR to purchase.... ~
LyndaB is offline   Reply With Quote
Old 06-22-2012, 09:35 PM   #7
Aquarium Advice Addict
 
Terrance's Avatar
 
Join Date: Jun 2011
Location: Seattle
Posts: 2,577
Your tank will end up being too small for a catfish and 2 puffers (assuming they are all young and small right now).
__________________

__________________
Kind Regards,
Terrance
Terrance is offline   Reply With Quote
Reply

Tags
die, died, filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners







All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.