Go Back   Aquarium Advice - Aquarium Forum Community > Freshwater > Freshwater & Brackish - General Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 05-30-2013, 07:19 PM   #1
Aquarium Advice Addict
 
cgthebeast's Avatar
 
Join Date: May 2013
Location: In a house
Posts: 3,085
So I changed my substrate to play sand, but now my tank is really cloudy and it's been 2 days and the tank is fully cycled. Any info would be great. I did rinse the sand.
Attached Thumbnails
Click image for larger version

Name:	image-2768389858.jpg
Views:	33
Size:	148.8 KB
ID:	177125   Click image for larger version

Name:	image-1814248189.jpg
Views:	29
Size:	146.0 KB
ID:	177127  

__________________
36 gallon fresh water

10g saltwater
cgthebeast is offline   Reply With Quote
Reply

Tags
sand, trouble

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners







All times are GMT -4. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.