Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater & Reef - Getting Started
Click Here to Login

Join Aquarium Advice Today
Closed Thread
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-05-2013, 05:32 PM   #1401
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
Continued maintenance today as I had an extra day off for all the work I did last week. I was able to catch another blurry picture of my betta, but today was more aimed at the powerheads. The smallest was totally clogged with the fast growing brown coraline algae that I have in my tank. Then there was the largest of my 2 powerheads covered in the red algae I've been battling. Got them as cleaned as I could, the stuff is extremely difficult to get off. While I had my arms in my tank, I noticed the webbing of vermited snails again...put a big stop to that by smashing 3 of them. One was obviously an original. Took a picture of it as well...this guy might be album worthy to show to people who have them in the future...so give me a second since photobucket is down.
__________________

Sniperhank is offline  
Old 11-05-2013, 05:35 PM   #1402
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
One Vermetid snail...
__________________

Sniperhank is offline  
Old 11-07-2013, 12:14 AM   #1403
Aquarium Advice Freak
 
Join Date: Sep 2012
Posts: 405
That's the largest vermetid snail I've ever seen. Wow!
__________________
NarwhalLover3 is offline  
Old 11-11-2013, 07:32 PM   #1404
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
Things continuing as planned. Manually removing algae from the "dead zones" in the front corners of my tank. Also been removing as much as I can from the rocks coral are on. I literally had an acan lord and my coco worm attached firmly together by algae growth! Either way, I'm still hopeful things are in the right direction. I'm even siphoning the sand in these dead zones to remove any possible decay.

On a side note, I finally have the 36 disassembled, emptied, and hauled onto the porch so I can forget about it again. Man was there a ton of gunk left over in there...no wonder that tank had issues. But that is why I started to siphon those dead spots. Things need to be pristine.
Sniperhank is offline  
Old 11-12-2013, 10:58 PM   #1405
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
An update that isn't in the 7 day cycle! I have continued working with the algae...I did a larger than normal water change the other day yatta yatta...and today I got around to removing algae from the sump...there is barely any! The battle won! This only leaves the one radion...it started with the power issue again today. Called 12 minutes after closing...aka when I got home from work. Either way, left a message to call me back and took a picture of the serial number so I can do it from work tomorrow when they call during my SCM instructors recert... But, the unit was built Feb 23rd 2012. One year warranty is on my side!
Sniperhank is offline  
Old 11-12-2013, 11:38 PM   #1406
Aquarium Advice Addict
 
Keithhjs's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 1,673
Quote:
Originally Posted by Sniperhank View Post
An update that isn't in the 7 day cycle! I have continued working with the algae...I did a larger than normal water change the other day yatta yatta...and today I got around to removing algae from the sump...there is barely any! The battle won! This only leaves the one radion...it started with the power issue again today. Called 12 minutes after closing...aka when I got home from work. Either way, left a message to call me back and took a picture of the serial number so I can do it from work tomorrow when they call during my SCM instructors recert... But, the unit was built Feb 23rd 2012. One year warranty is on my side!
Glad to hear the algae is getting better. Now I just hope Ecotech gives you some good news too!
__________________
Keithhjs is offline  
Old 11-12-2013, 11:44 PM   #1407
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
I don't see why they won't. If not...Xmas is coming...
Sniperhank is offline  
Old 11-13-2013, 06:00 PM   #1408
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
Good news everyone! I got off the phone with Ecotech. Good people who def worked hard to keep up with me and the fact I've been working straight since the initial email. The radion is still under warranty, like figured, and so the power supply is being replaced. "Well, that's good news Hank" you say? Not only that, they are sending me a brand new Radion to go with it! And this is why I'm happy about going with radions instead of the knock offs or any other brand. New unit will be here Friday.
Sniperhank is offline  
Old 11-13-2013, 06:22 PM   #1409
Aquarium Advice Addict
 
Hondatek's Avatar



POTM Champion
 
Join Date: May 2011
Location: Virginia Beach
Posts: 3,993
So your sending me the new one as a gift correct ?
__________________
Feed your Filtration
Give it to Porc Chop he'll eat anything!!!!!
"This is my tank and these other fish just live in it"
^ Quoted from Porc Chop^
Hondatek is offline  
Old 11-13-2013, 10:25 PM   #1410
Aquarium Advice Addict
 
Keithhjs's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 1,673
Quote:
Originally Posted by Hondatek View Post
So your sending me the new one as a gift correct ?
Uh, I thought he was sending me the used one lol!
__________________
Keithhjs is offline  
Old 11-13-2013, 10:28 PM   #1411
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
You mean, find a power supply for the other one and I have lighting for an upgraded tank? Yeah, things are really looking up!
Sniperhank is offline  
Old 11-18-2013, 04:47 PM   #1412
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
I couldn't help myself when I was out at court today...

Pick up an awesome macro algae? Yes please! Are there green and red mushrooms on it? Yes there are!
Sniperhank is offline  
Old 11-18-2013, 06:50 PM   #1413
Aquarium Advice Addict
 
Dary421's Avatar



Tank of the Month Award
 
Join Date: Oct 2010
Location: San Diego,ca
Posts: 2,927
Quote:
Originally Posted by Sniperhank View Post
I couldn't help myself when I was out at court today... Pick up an awesome macro algae? Yes please! Are there green and red mushrooms on it? Yes there are!
i
Its a sickness i tell you... Reefitis or something we all have ... Looks cool .. How much did you have to spend ?
__________________
Dary421 is offline  
Old 11-18-2013, 06:53 PM   #1414
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
It was 50. But mushroom rocks are normally 50 at Petco...and I've paid an arm and a leg for a macro before. Winning all around I think.
Sniperhank is offline  
Old 11-18-2013, 06:58 PM   #1415
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
Oh, and the new Radion arrived today too...just haven't got around to it.
Sniperhank is offline  
Old 11-18-2013, 09:01 PM   #1416
Aquarium Advice Addict
 
Keithhjs's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 1,673
Love the red macro & congrats on the new light.
__________________
Keithhjs is offline  
Old 11-18-2013, 09:02 PM   #1417
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
Worst part is that since calling the warranty in there haven't been any issues. Drives me nuts. Still replacing.
Sniperhank is offline  
Old 11-18-2013, 11:14 PM   #1418
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
I was also excited to see a large marine beta when they were bagging up my rock. I can't wait Til mine is that size...he is getting bigger. He'd prob get more to eat if I didn't have the coral beauty...I justify getting rid of that thing all the time...
Sniperhank is offline  
Old 11-19-2013, 07:52 PM   #1419
Giant Clam Addict
Community Admin
 
Sniperhank's Avatar



POTM Champion
 
Join Date: Nov 2011
Location: Summerville, Pennsylvania
Posts: 20,245
Still haven't hooked up the new radion. I'm sitting infront of the tank baffled about how the one that is supposed to be bad is working fine ever since Ecotech saying they'd replace it. Not the reason I haven't switched them. The laptop my graph is on is a POS and takes 30 minutes to boot up. Going to utilize the fiancee's laptop to do so, just have to switch that all first.

The red macro is still doing well. The mushrooms are still as small and pitiful as they were when I pulled them out of that awful tank.

Continuing to pull algae out of the tank, but it is so much less than before it is almost like not having to work at all. Still believe if I could get an ATS going on the system I wouldn't be doing this at all...slow but sure process.
Sniperhank is offline  
Old 11-19-2013, 08:44 PM   #1420
Aquarium Advice Addict
 
Dary421's Avatar



Tank of the Month Award
 
Join Date: Oct 2010
Location: San Diego,ca
Posts: 2,927
Quote:
Originally Posted by Sniperhank View Post
Still haven't hooked up the new radion. I'm sitting infront of the tank baffled about how the one that is supposed to be bad is working fine ever since Ecotech saying they'd replace it. Not the reason I haven't switched them. The laptop my graph is on is a POS and takes 30 minutes to boot up. Going to utilize the fiancee's laptop to do so, just have to switch that all first.

The red macro is still doing well. The mushrooms are still as small and pitiful as they were when I pulled them out of that awful tank.

Continuing to pull algae out of the tank, but it is so much less than before it is almost like not having to work at all. Still believe if I could get an ATS going on the system I wouldn't be doing this at all...slow but sure process.
It's like calling the dentist cuz you've got a horrendous toothache but once you actually get to the dentist office it doesn't hurt anymore and you wanna try to slide you *** out the door and make an escape before you really hurt !!!
If memory serves mre right doesn't ecotech have a rather strict return policy ?
__________________

__________________
Dary421 is offline  
Closed Thread

Tags
55 gallon, build, reef build, upgrade

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners







All times are GMT -4. The time now is 02:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.