Go Back   Aquarium Advice - Aquarium Forum Community > Freshwater > Freshwater & Brackish - Getting Started
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 08-30-2014, 08:18 AM   #1
Aquarium Advice Freak
 
KatieBunky's Avatar
 
Join Date: Apr 2014
Location: Buckinghamshire, England
Posts: 253
Experienced but confused...

I've kept fish for 8 years but I'm terrible at all of the equipment stuff.

I got a used 24 gallon tank yesterday from a friend & the filter seems a bit iffy. It worked fine at my friends but I took it all apart when I got it home, gave the sponges a very brief wash in a bucket of tank water because they were covered in dead pest snails & put it back together.

It seems to work but it gives a sudden "woosh" about every 30 seconds. That's the best way I can describe it. Should I just give the sponges a wiggle? The suction cups on the filter are so strong so I can't take the whole thing out.

Also, the water smells quite chemically & plasticy, I did only put it in yesterday but is that normal? Is it ammonia? It's still a bit cloudy & the gravel from my lfs was really dirty & I washed it about 5 times & it was still really dusty so I just put it in the tank & hoped the filter would sort it out.

I'm going to be using all of the gravel from my old tank to get it up & running quicker. I really need to get my fish in as soon as possible as their current tank is far too small.

I tested the water & it came back as:
NO3- 0 or 10, it was hard to tell
NO2- 0
GH- 8
KH- 10
pH- 7.6
Cl2- 0

So my questions come down to these:
What's up with the filter?
Why does the water smell weird?
Are the parameters okay to put my fish in?

Thanks in advance

Typically British!
__________________

__________________
Typically British!
KatieBunky is offline   Reply With Quote
Old 08-30-2014, 08:37 AM   #2
Aquarium Advice Freak
 
KatieBunky's Avatar
 
Join Date: Apr 2014
Location: Buckinghamshire, England
Posts: 253
Just found out it's the filter in my current tank that's not working. Omg I'm so dim XD

Typically British!
__________________
Typically British!
KatieBunky is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi guys, some help from experienced fichkeepers please reloaded316 Freshwater & Brackish - General Discussion 10 04-03-2005 02:47 PM
question for those experienced working with acrylics... guitarded DIY Projects 15 01-07-2005 01:05 PM
Moving 3 Tanks, experienced advice? Sneaker Saltwater Reef Aquaria 4 03-29-2004 09:23 AM
I need experienced advice on Carpet Anenome, please kidafius Saltwater Reef Aquaria 5 01-03-2004 10:53 AM
My Sponge Is it Good or Bad? I am an Experienced Aquarist. GreatDeep Saltwater Reef Aquaria 4 10-04-2003 07:27 PM







» Photo Contest Winners







All times are GMT -4. The time now is 10:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.