Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 02-16-2022, 08:47 PM   #1
Aquarium Advice Newbie
 
Join Date: Feb 2022
Posts: 5
Aqueon power filter not working

Hi everyone.

Earlier this evening there was a power glitch at my place.

My aqueon power filter 50-75 is on a small power bar with no surge protector. Now the filter is not working. What can I do to get it running?

__________________
Kris182 is offline   Reply With Quote
Old 02-16-2022, 09:23 PM   #2
Aquarium Advice Activist
 
Join Date: Aug 2021
Location: Middletown NY
Posts: 181
Unless it fried during the power surge......

That is not an uncommon problem with the Aqueon HOB filters.
However it is an easy and quick fix,
The reason is, after a while debris collects in the impeller chamber and on the impeller its self ......and this stops it from spinning.. It does not take much for this to happen.
Sometimes if it is dirty, it will not even restart if power is interrupted for a couple seconds.

Anyway, you just have to clean it and it is really simple and quick.
Just take the pump assembly apart at the joint.... it is just a snug friction fit\
There is one big clip that secures it but you can't miss it
When apart, you will then see the impeller and the impeller chamber
Then clean it and put is back together.... and it will pump like new

BTW it's good idea to put a foam pre filer on the intake as it will filter out much crap before it gets to the impeller. It even extends the life of the filter cartridge
That is what I do.. .

.
__________________
Joe_D is offline   Reply With Quote
Old 02-16-2022, 09:53 PM   #3
Aquarium Advice Newbie
 
Join Date: Feb 2022
Posts: 5
Thanks. I have a prefilter on the intake, but it's not long enough to cover the entire intake.

The filter is heavy for me, so I'll have to try to empty it prior to taking it out.
__________________
Kris182 is offline   Reply With Quote
Old 02-16-2022, 11:26 PM   #4
Aquarium Advice Activist
 
Join Date: Aug 2021
Location: Middletown NY
Posts: 181
Yeah you will figure it out\.

This is what I do..
Un plug it of course,

First,, I take out the small blue holder.
Then I lift up up the filter and pour most of the water back in the tank
You want to initially to quickly put the filer in something to catch all the remaining water. I use a old small plastic basin.

BTW that small blue holder is supposed to be for an anti ammonia rectangle,
However, with a cycled tank ,you do not need that
So, I put it to better use by putting some ceramic bio rings in it.
__________________
Joe_D is offline   Reply With Quote
Old 02-17-2022, 01:01 PM   #5
Aquarium Advice Newbie
 
Join Date: Feb 2022
Posts: 5
So I'm trying to get the impeller housing to come off but it refuses to budge. I've attached a photo of the area I'm talking about. I can remove the entire motor housing, but that's it.

How do I get this to come off without breaking it?
Attached Thumbnails
Click image for larger version

Name:	20220217_125801.jpg
Views:	12
Size:	89.8 KB
ID:	322944  
__________________
Kris182 is offline   Reply With Quote
Old 02-17-2022, 03:01 PM   #6
Aquarium Advice Newbie
 
Join Date: Feb 2022
Posts: 5
So I managed to get the impeller housing off, it really wasn't dirty, and I got the filter working again.

Thanks for the help.
__________________
Kris182 is offline   Reply With Quote
Old 02-17-2022, 04:38 PM   #7
Aquarium Advice Activist
 
Join Date: Aug 2021
Location: Middletown NY
Posts: 181
Great ..
Like I said, sometimes it does not take much to stop the impeller

BTW. the housing is a tight friction and you might of had some crud around the joint making it that much harder to take off.

Anyway, now you know exactly what to do if it stops again.
__________________
Joe_D is offline   Reply With Quote
Reply

Tags
aqueon, filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brand new Aqueon Quietflow 75 LED Pro not working finnafish General Hardware/Equipment Discussion 11 03-09-2017 08:55 AM
Aqueon LED Not Working?!? kpreece General Hardware/Equipment Discussion 1 02-03-2017 09:58 AM
Aqueon filter not working Dubs1281 General Hardware/Equipment Discussion 17 08-04-2013 04:18 PM
aqueon pump stopped working animalzrok2 General Hardware/Equipment Discussion 3 02-13-2013 09:27 AM
Aqueon HOB not working... N757QQ Freshwater & Brackish - Getting Started 3 07-15-2012 10:41 PM







» Photo Contest Winners







All times are GMT -4. The time now is 03:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.