Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-01-2021, 11:14 PM   #1
Aquarium Advice Newbie
 
Doejoe's Avatar
 
Join Date: Mar 2021
Location: Northeast, Md
Posts: 3
Sunsun 703B heeellllpp!

Found this stupid thing at a price I couldnít pass up. I can NOT get the **** thing to pump. ALL hoses are full of water. Motor running. Nothing. Absolutely nothing. Just sits there. YouTube/google= no help whatsoever.
Last resort before the countdown to launch. Iíll notify you when to look out your windows and in what direction to watch it go up in a blaze of unglorified smoke
__________________

__________________
Doejoe is offline   Reply With Quote
Old 03-01-2021, 11:28 PM   #2
Aquarium Advice Regular
 
LaloJ's Avatar
 
Join Date: Mar 2021
Location: Mexico
Posts: 54
Do you mean that your canister filter just doesn't work? Have you checked if it has something that is obstructing both the outlet and the inlet of the filter? Does the engine have good power yet? Frankly, I have always preferred HOB filters, which are easier to maintain.
__________________

__________________
LaloJ is offline   Reply With Quote
Old 03-02-2021, 02:49 AM   #3
Aquarium Advice Addict
 
Aiken Drum's Avatar
 
Join Date: Apr 2019
Location: Derbyshire, UK
Posts: 1,040
I know this is a different filter, but the primer not working properly is a common issue with fluval cannisters and this is a solution for those which might work on yours.

https://youtu.be/1rOcsYu-nvI

Otherwise old fashioned suction on the intake pipe, ive resorted to that as well.
__________________
Aiken Drum
Aiken Drum is offline   Reply With Quote
Old 03-02-2021, 02:57 AM   #4
Aquarium Advice Addict
 
charliebankston's Avatar
 
Join Date: Aug 2020
Location: Texas Gulf coast
Posts: 2,016
Make sure the impeller is installed correctly, the cover plate is installed correctly over the impeller, and that it's turning properly on its little ceramic shaft
__________________
charliebankston is offline   Reply With Quote
Old 03-02-2021, 02:59 AM   #5
Aquarium Advice Addict
 
charliebankston's Avatar
 
Join Date: Aug 2020
Location: Texas Gulf coast
Posts: 2,016
I have over 10 sunsun canisters running right now. I love them.
__________________
charliebankston is offline   Reply With Quote
Old 03-02-2021, 06:38 AM   #6
Aquarium Advice Newbie
 
Doejoe's Avatar
 
Join Date: Mar 2021
Location: Northeast, Md
Posts: 3
This is my first go at a canister. Always been a HOB guy so I understand. Looking for a quieter, neater option.
Yes, I’ve tried all you mentioned and more.. I work with my hands and use common sense but this thing has me baffled.
Thx
__________________
Doejoe is offline   Reply With Quote
Old 03-02-2021, 07:22 AM   #7
Aquarium Advice FINatic
 
Join Date: Feb 2020
Posts: 621
MIght as well check the stator to see if it works. Take off the head unit, turn it upside down. Remove the impeller. Plug the unit back in. Take a screwdriver and put it in the hole and move it all around. It should pull to all sides everywhere. Check for a weak spot.
__________________
fishwonder is offline   Reply With Quote
Old 03-02-2021, 09:12 AM   #8
Aquarium Advice Addict
 
charliebankston's Avatar
 
Join Date: Aug 2020
Location: Texas Gulf coast
Posts: 2,016
I had one rattling and not pumping good, couldn't figure it out. Then after multiple times looking at it I realized the ceramic shaft on the impeller was broken. Got a new piece, works great now. With no water flow, I gotta think it's something with the impeller or magnetic drive like FW said
__________________

__________________
charliebankston is offline   Reply With Quote
Reply

Tags
eel

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sunsun canister filter josh7 General Hardware/Equipment Discussion 9 06-04-2012 01:37 PM
New SunSun filter krap101 General Hardware/Equipment Discussion 11 07-31-2010 01:38 AM
sunsun power head divedeep1689 General Hardware/Equipment Discussion 6 07-05-2010 09:24 AM
Sunsun HW-303 canister media mogget General Hardware/Equipment Discussion 0 04-16-2009 06:02 PM
SUNSUN 303 Canister Aquarium Filter Built-In 9W UV Sterilizer fort384 General Hardware/Equipment Discussion 2 02-21-2009 07:03 AM







» Photo Contest Winners







All times are GMT -4. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.