Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-28-2011, 10:00 PM   #1
Aquarium Advice Regular
 
Join Date: Apr 2011
Location: Pa
Posts: 89
Sea Cucumber and zoanthids?

Looking to get a zoanthid frag and a pink sea cucumber. What do you guys think? My tank cycled about 2 weeks ago everything lookin really good except the hair algae problem.
__________________

__________________
JVS__RAMBO is offline   Reply With Quote
Old 06-28-2011, 10:41 PM   #2
Aquarium Advice FINatic
 
Join Date: Apr 2011
Location: Kansas
Posts: 717
Take care of the HA problem first would be my advice. If it's there it means there are still excess nutrients that corals wouldn't like very much. A newly cycled tank can still fluctuate quite a bit and sensitive creatures wont take to kindly to it. Be proactive instead of reactive.
__________________

__________________
Sergie is offline   Reply With Quote
Old 06-28-2011, 10:57 PM   #3
Aquarium Advice Regular
 
Join Date: Apr 2011
Location: Pa
Posts: 89
Ya, I am gonna wait. Trying to get rid of the hair algae now and detritis on the sand. Snails just don't seem to do the trick and my lawnmower blenny can't seem to put a dent in it.
__________________
JVS__RAMBO is offline   Reply With Quote
Old 06-28-2011, 11:04 PM   #4
Aquarium Advice FINatic
 
Join Date: Apr 2011
Location: Kansas
Posts: 717
Hmmm....sounds like your tank is trying to finish cycling. Have you done any tests lately? What were your results? Did you start the tank two weeks ago or did you think it finished cycling two weeks ago? How big is the tank and how much live rock do you have?

Alot of questions, I know. I'm just trying to help you get through this algae bloom faster.
__________________
Sergie is offline   Reply With Quote
Old 06-29-2011, 12:12 AM   #5
Aquarium Advice Regular
 
Join Date: Apr 2011
Location: Pa
Posts: 89
It cycled two weeks ago. 120g tank with 120lbs live rock 20lbs live sand in refugium, 10 lbs live sand in tank. 160 lbs of regular sand in tank. Ph 8.0 Amm 0 nitrite 0 nitrate 0-5. Not sure if my phosphates are high been doing 10 gallons water changes since it cycled so it don't look like its growing anymore just the stuff I have is getting longer. Oh my Alk is 9
__________________
JVS__RAMBO is offline   Reply With Quote
Reply

Tags
cuc, sea, zoanthid, zoanthids

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 09:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.