Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-24-2012, 08:11 PM   #1
Aquarium Advice Activist
 
Daddy-o's Avatar
 
Join Date: Oct 2011
Posts: 135
Urchin Hiding?

Just put this new Urchin in my tank yesterday. Came home this afternoon and found him in this crevice. Tried to remove some sand and pull him out, but did not want to hurt him. Is this normal?
Attached Thumbnails
Click image for larger version

Name:	image-4027387136.jpg
Views:	48
Size:	156.6 KB
ID:	102674  
__________________

__________________
Daddy-o is offline   Reply With Quote
Old 06-24-2012, 08:14 PM   #2
Aquarium Advice Activist
 
Daddy-o's Avatar
 
Join Date: Oct 2011
Posts: 135
Uggh, long day... Not an urchin, an anemone.
__________________

__________________
Daddy-o is offline   Reply With Quote
Old 06-24-2012, 09:11 PM   #3
Aquarium Advice Addict
 
Schism's Avatar
 
Join Date: Dec 2011
Location: Lima, Ohio
Posts: 2,093
Quote:
Originally Posted by Daddy-o
Uggh, long day... Not an urchin, an anemone.
Yep nem it looks like, i would return it unless you have the proper lighting and parameters.
__________________
29g Mixed Reef, 150w 14k Phoenix MH w/ Moonlights, Reef Octopus BH1000 HOB Skimmer, Ecotech Vortech MP10es, ReefKeeper Lite (Plus), PH Probe, Temp Probe, ATO, Carbon/GFO Reactor.
Schism is offline   Reply With Quote
Old 06-24-2012, 10:26 PM   #4
Aquarium Advice Activist
 
Daddy-o's Avatar
 
Join Date: Oct 2011
Posts: 135
Sorry, I don't follow what you are saying. Return to LFS? He has actually turned around now. Just an acclimation issue?
__________________
Daddy-o is offline   Reply With Quote
Old 06-24-2012, 10:36 PM   #5
Aquarium Advice Addict
 
crister13's Avatar
 
Join Date: Aug 2011
Location: Princeton, NJ
Posts: 3,473
What lighting do you have? What are your parameters???
__________________
crister13 is offline   Reply With Quote
Old 06-24-2012, 10:57 PM   #6
Aquarium Advice Activist
 
Daddy-o's Avatar
 
Join Date: Oct 2011
Posts: 135
AI Sol's at 60% for about 8 hrs. All parameters are normal. Salt 1.025, pH 8.1, etc....
__________________
Daddy-o is offline   Reply With Quote
Old 06-24-2012, 11:34 PM   #7
Aquarium Advice Addict
 
crister13's Avatar
 
Join Date: Aug 2011
Location: Princeton, NJ
Posts: 3,473
That's definitely fine then.
__________________
crister13 is offline   Reply With Quote
Old 06-25-2012, 12:33 AM   #8
Aquarium Advice Addict
 
Schism's Avatar
 
Join Date: Dec 2011
Location: Lima, Ohio
Posts: 2,093
Yea thats fine. I was just saying because it sounded like you didn't know it was a nem so i figured you probably also were not aware of there much higher care requirements then urchins
__________________

__________________
29g Mixed Reef, 150w 14k Phoenix MH w/ Moonlights, Reef Octopus BH1000 HOB Skimmer, Ecotech Vortech MP10es, ReefKeeper Lite (Plus), PH Probe, Temp Probe, ATO, Carbon/GFO Reactor.
Schism is offline   Reply With Quote
Reply

Tags
chi, hiding, urchin

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 06:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.