Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Fish Only & FOWLR
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 12-24-2013, 12:24 AM   #1
Aquarium Advice Apprentice
 
DeaFkiD's Avatar
 
Join Date: Nov 2013
Location: Albuquerque, nm
Posts: 25
Need help!!!!!!!

Hey I need help... I have lost 3 fish in the last 2 month a goby and two damsels my parameters are 8.0, 0, 0, 0, and salinity is .025 what is going on I still have an emerald crab, 7 turbo snails and a yellow tang, and a chocolate chip starfish with no issues, what am I missing? Please help with what I am missing!!!
__________________

__________________
DeaFkiD is offline   Reply With Quote
Old 12-24-2013, 03:14 PM   #2
Aquarium Advice Freak
 
Airgoose2222's Avatar
 
Join Date: Apr 2013
Posts: 442
Tang may have beaten up the other fish.
__________________

__________________
Airgoose2222 is offline   Reply With Quote
Old 12-24-2013, 04:11 PM   #3
Aquarium Advice Apprentice
 
DeaFkiD's Avatar
 
Join Date: Nov 2013
Location: Albuquerque, nm
Posts: 25
Ok but my damsel were starting to look on the grey side is that any thing that could help
__________________
DeaFkiD is offline   Reply With Quote
Old 12-24-2013, 05:07 PM   #4
Aquarium Advice Addict
 
Join Date: Jan 2009
Location: new york
Posts: 1,321
Your ph is a little low but that didn't cause the fish to die it could just have been their time I don't see anything that could have cause them to die. I doubt the tang was bothering those fish and I doubt enough to cause their demise.
__________________
tonedogz is offline   Reply With Quote
Old 12-28-2013, 12:29 AM   #5
Aquarium Advice Freak
 
Join Date: Nov 2012
Posts: 234
How big is the tank? Was everyone eating before they died?
__________________
Jasonrusso is offline   Reply With Quote
Old 12-28-2013, 12:32 AM   #6
Aquarium Advice Apprentice
 
DeaFkiD's Avatar
 
Join Date: Nov 2013
Location: Albuquerque, nm
Posts: 25
It's 110 gallon and yes all were eating normal
__________________

__________________
DeaFkiD is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 11:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.