Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 12-06-2008, 08:18 PM   #1
Aquarium Advice Activist
Join Date: Nov 2006
Posts: 112
CF light stopped working...can i fix it?

My CF 2x55 just stopped working. It is 3 or 4 years old.

Maybe the balast just went out?

Can you buy balasts at the big hardware stores?

Any help/advice would be appreciated.

PITT is offline   Reply With Quote
Old 12-07-2008, 12:28 PM   #2
AA Team Emeritus
jsoong's Avatar

Join Date: Aug 2003
Location: Edmonton, Canada
Posts: 4,222
Before you blame the ballast, you might want to check the wiring, switch & end caps. It is more likely that corrosion had caused a fault in the wiring. A good ballast should last more than 3 or 4 years.

You prob can't find a suitable ballast at the hardware store. What you need is an electronic load sensing ballast of at least 110W. <2x 55 usu. have 130W ballasts, so you can interchange the 55 & 65 bulbs.> You might be able to find electronic ballasts for T8 shop lights of 64 W or so. 2 of those might work. <There is no guarantee that the cheap shoplight ballasts will be load sensing, but 65W ballasts should drive the 55W PC .... YMMV> Your best bet to find a good ballast is at a specialized lighting store or on line.
80 gal FW with 30 gal DIY wet/dry/sump.
9 fancy golds, 1 hillstream loaches, 1 rubber-lip pleco (C. thomasi), 3 SAEs, small school of white cloud minnows, planted.
jsoong is offline   Reply With Quote


Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Light Stopped working jibboo General Hardware/Equipment Discussion 15 06-24-2009 10:57 AM
Juwel 180 light unit has stopped working?!! HELP!! ChuckBay Freshwater & Brackish - General Discussion 2 03-29-2009 08:24 PM
Pressurized Co2 Stopped Working - PLEASE HELP PrettyFishies Freshwater & Brackish - Planted Tanks 3 09-10-2007 10:16 PM
Eclipse 3 stopped working swanandmokashi Freshwater & Brackish - General Discussion 5 11-11-2004 09:48 AM
HELP! Filter stopped working! techiegirl General Hardware/Equipment Discussion 7 08-13-2004 02:38 AM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 05:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.