Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-02-2011, 12:49 PM   #1
Aquarium Advice Freak
 
Kelso's Avatar
 
Join Date: Oct 2009
Location: Connecticut
Posts: 382
Heater Issues

I bought a marineland 250w heater for my tanks out a month ago. Ive been having trouble all winter long trying to keep the tanks at a level temp. I have a 40 breeder with two 20 gal plummed in. I have kept the heaters in my sump. When I finally got the marineland heater it kept everything perfect at 80, was doing so for the past month.

I woke up this morning and found my display was at 68.8 degrees. The heater light was on but apparently not doing anything. I felt it and it seemed cool. So I took the 100w heater out of my bin I got live rock curing in therw it in the sump and put the marineland in the bin. Its keeping the bin at an even 80, weird.

So besides the long explination, is the marineland heater shot? Or is there anything I can do to fix it?
__________________

__________________
Kelso is offline   Reply With Quote
Old 03-02-2011, 01:45 PM   #2
Aquarium Advice FINatic
 
itsgracia's Avatar
 
Join Date: Feb 2011
Location: California
Posts: 1,209
Is it the Stealth Pro one? If so, ML has a stop sale on these. I know that some Petco would take them back (not all). If you call ML they will send you the VisiTherm one in 7-10 days.

Also just a suggestion, its always good to have 2 heaters just in case one fails. Hope this helped.
__________________

__________________
itsgracia is offline   Reply With Quote
Old 03-02-2011, 03:08 PM   #3
Aquarium Advice Freak
 
Kelso's Avatar
 
Join Date: Oct 2009
Location: Connecticut
Posts: 382
I did get it at petco, dont have the box anymore but will look into the name. Thanks.
__________________
Kelso is offline   Reply With Quote
Old 03-02-2011, 03:14 PM   #4
Aquarium Advice FINatic
 
itsgracia's Avatar
 
Join Date: Feb 2011
Location: California
Posts: 1,209
If it's the Stealth Pro, it will say so on one side of the heater in red writing. Also the Stealth Pro is the one with the indicator light on the adjustment knob (the one that turns green when off and red when on)

Contact your local Petco if they would take it (they should but some don't like mines). If not contact ML's customer relations for a replacement.
__________________
itsgracia is offline   Reply With Quote
Old 03-02-2011, 03:18 PM   #5
Aquarium Advice Freak
 
Kelso's Avatar
 
Join Date: Oct 2009
Location: Connecticut
Posts: 382
ya the indacatior light does go from red to green, that I know. Is the replacement free? And what should I tell them, I bought a stelth pro from my local petco and heard they were discontinued so I would like a replacement?
__________________
Kelso is offline   Reply With Quote
Old 03-02-2011, 03:24 PM   #6
Aquarium Advice FINatic
 
itsgracia's Avatar
 
Join Date: Feb 2011
Location: California
Posts: 1,209
What I did was call my Petco they told me to come to the store with the heater and suction cups it came with (I have another heater in the tank) and when I got there, they had no clue about the stop sale. I left the store and called ML's customer relations (you can find their number on their website) and told them that I got a Pro from Petco and would like it replaced. They asked for my name and address and that's it. They told me it takes 7-10 days for it to arrive. I really like ML's customer service its A++ for me. Good luck!

Oh yes and the replacement is free!
__________________
itsgracia is offline   Reply With Quote
Old 03-02-2011, 03:31 PM   #7
Aquarium Advice Freak
 
Kelso's Avatar
 
Join Date: Oct 2009
Location: Connecticut
Posts: 382
Thank you, thats perfect.
__________________

__________________
Kelso is offline   Reply With Quote
Reply

Tags
eat, eater, heater

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater Issues Bnortz General Hardware/Equipment Discussion 8 01-30-2011 02:50 AM
In-Sump Heater vs. In-Tank Heater Aquaman99 General Hardware/Equipment Discussion 2 05-13-2010 06:24 PM
heater issues happygirl65 Freshwater & Brackish - General Discussion 11 11-11-2006 05:06 PM
Ya know I think my heater died o.o -- Disposal issues.... Puriti Freshwater & Brackish - General Discussion 11 08-29-2005 06:23 PM
Heater issues in FO 46 gallon?? Phiberop Saltwater Fish Only & FOWLR 8 02-02-2004 01:30 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.