Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 05-28-2005, 01:37 AM   #1
Aquarium Advice Freak
 
Join Date: Oct 2004
Location: north idaho
Posts: 470
Send a message via AIM to megladonsharky Send a message via MSN to megladonsharky Send a message via Yahoo to megladonsharky
need help filter broke

My 3-4 gallon tank has a small critter keeper filter and a eclipse mini in it .. we today the mini broke a propeeller possible lfs said .. so I took the critter keeper line and put in an airstone an wraped a nitasorb(spelling ) around it with a rubber band..

Is this safe ?? the store was out of the kritter cartiges and they arent working as well as they used to ;....I did get a in coner pen plax at petco but forgot it at the store after I pd for it... My mind is out ..lmao...

Any ideas and help welcome
__________________

__________________
megladonsharky is offline   Reply With Quote
Old 05-28-2005, 01:59 AM   #2
Aquarium Advice Addict
 
Join Date: Aug 2004
Location: Washington
Posts: 4,168
If you can get a ten gallon tank and a small hob, I think your fishies would be very happy
For now, you should be ok with no filter. Just do daily partial water changes of about 50%.
__________________

__________________
Meredith is offline   Reply With Quote
Old 05-28-2005, 02:05 AM   #3
Aquarium Advice Addict
 
krap101's Avatar
 
Join Date: Feb 2004
Location: Roscoe, IL
Posts: 6,084
Send a message via AIM to krap101
anyway... how'd you break the impeller?
__________________
~ Danny
krap101 is offline   Reply With Quote
Old 05-28-2005, 02:10 AM   #4
Aquarium Advice Freak
 
Join Date: Oct 2004
Location: north idaho
Posts: 470
Send a message via AIM to megladonsharky Send a message via MSN to megladonsharky Send a message via Yahoo to megladonsharky
I aint sure.. I may have had some debis in it that i didnt see

as for the ten gallon theyd be lost... and they dont like heat... I have white clouds in it...
__________________
two gallon with 16 gph filter with live plants and a female betta named Meloday

3-4 gallon with 80gph ... Planted lightly three white clouds ( Birtha Clara and Delila) and some snails (mainly melodys snacks)

9 gallon with 130gph , heated with male betta (Trafalger RIP)Kaden ( a male betta)has moved in, pygmy cory (MaMa) , pitbull pleco(Metal), three preacox rainbows( Annabel, Glitter and Mondo) and various snails...
megladonsharky is offline   Reply With Quote
Old 05-28-2005, 02:56 AM   #5
Aquarium Advice Freak
 
Join Date: Oct 2004
Location: north idaho
Posts: 470
Send a message via AIM to megladonsharky Send a message via MSN to megladonsharky Send a message via Yahoo to megladonsharky
Thank you... But I fixed it after finding out what an impeller was
__________________
two gallon with 16 gph filter with live plants and a female betta named Meloday

3-4 gallon with 80gph ... Planted lightly three white clouds ( Birtha Clara and Delila) and some snails (mainly melodys snacks)

9 gallon with 130gph , heated with male betta (Trafalger RIP)Kaden ( a male betta)has moved in, pygmy cory (MaMa) , pitbull pleco(Metal), three preacox rainbows( Annabel, Glitter and Mondo) and various snails...
megladonsharky is offline   Reply With Quote
Reply

Tags
filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater broke??? newfishhobbyist Freshwater & Brackish - Getting Started 18 05-25-2009 07:13 PM
Broke my filter :( cghill General Hardware/Equipment Discussion 15 04-11-2006 04:21 AM
broke down and did it morgan24 General Hardware/Equipment Discussion 1 02-21-2006 08:41 PM
Maybe our filter broke? djmpj2 General Hardware/Equipment Discussion 12 03-19-2005 06:02 PM
Problem: Carbon Filter Bag Broke. rvijay07 Freshwater & Brackish - General Discussion 8 03-04-2005 08:46 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 01:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.