Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 11-07-2011, 03:44 AM   #1
Aquarium Advice Regular
donica_anne's Avatar
Join Date: Oct 2011
Location: Wa state
Posts: 64
petco 50W heater making noise??

my heater makes an odd clunk/glub noise when its on....like a few times and small bubbles come off the end...I did a water change today and was super careful to let it sit after unplugging it and then before I plugged it back in...also before I had the other suction cup all the way at the bottom end of the heater and I noticed there was white markings on the glass under where the suction cup clips to it..... anyways I moved that up so both clips are at the top above the elements. Not sure if I fixed the problem, and I'm kind of wondering if anyone else has experienced this? Also its regulating the temp just fine, its just worrying me a little!! Any input would be helpful!!!! Thanks!

donica_anne is offline   Reply With Quote
Old 11-07-2011, 05:17 AM   #2
Aquarium Advice FINatic
Join Date: May 2011
Location: mason City, iowa
Posts: 552
A heater shouldn't make any noise, and the bubbles could mean you have water seeping in the heater. I would take it back asap.
ocean is offline   Reply With Quote

eat, eater, heater, noise, petco

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Angels Making Noise Bubbles? Coltrane9 Freshwater & Brackish - General Discussion 3 09-07-2011 10:10 AM
Fluval e50 Heater Brian_Nano12g General Hardware/Equipment Discussion 3 08-31-2011 02:40 PM
Aquaclear 50 making noise Aspencer General Hardware/Equipment Discussion 4 07-27-2011 12:23 PM
Hydor Theo heater malfunctioning? Aqua315 Freshwater & Brackish - General Discussion 0 07-04-2011 07:01 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 06:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.